Úvodní práce v Geogebře
GeoGebra jako sešit a kalkulačka
Ivo Voska
Obsah
Úvodní otázky pro práci s Geogebrou..................................................................................................1
Proč GeoGebra? ..............................................................................................................................1
Co je GeoGebra?..............................................................................................................................2
Jak si Geogebru nainstaluji na svůj počítač?...................................................................................2
Musím mít GeoGebru nainstalovanou na svém počítači, abych s ní mohl(-a) pracovat?..............2
Představení GeoGebry..........................................................................................................................3
Co uvidíš po spuštění GeoGebry na svém počítači?........................................................................3
Mohu si teď vyzkoušet jak GeoGebra funguje?..............................................................................4
Mohu si svoji práci uložit?...............................................................................................................4
Mám GeoGebru stále v angličtině, co mám dělat?..........................................................................4
Opravdový začátek...............................................................................................................................6
Kde mám začít a jak porozumím práci v GeoGebře?......................................................................6
Jak provedu jednoduché matematické operace?..............................................................................6
Co je to proměnná a jaký význam má její jméno?...........................................................................7
Jaké to má výhody? Jen byl celý postup několikrát delší................................................................9
Už je to lepší. Nelíbí se mi způsob zápisu výsledku. Je možné ho zapsat jinak přehledněji?.........9
Vstupní řádek se podobá svými funkcemi kalkulačce? Je možné najít některé konstanty nebo
funkce podobně jako na kalkulačce?.............................................................................................10
Existuje nějaký seznam matematických funkcí, které lze zadat do vstupního řádku?..................12
Je možné měnit u výsledku, který jsem získal z GeoGebry počet zobrazených desetinných míst?
.......................................................................................................................................................13
Obvykle programy obsahují tzv. klávesové zkratky, které urychlují práci v programu. Má je i
GeoGebra?.....................................................................................................................................13
Jak se v GeoGebře zobrazují čísla. Jsou vždy zaokrouhlena na dvě desetinná místa?..................18
Jak v GeoGebře zapsat velmi malá nebo naopak velmi velká čísla?.............................................18
Závěrečné příklady k procvičení....................................................................................................18
Proč GeoGebra?
Protože ti pomůže utvořit si ucelenou představu o matematických pojmech středoškolského
učiva. Nahradí a vylepší tvoji kalkulačku, sešit, tabulky a různé rýsovací pomůcky a nástroje.
Zrychlí tvoji práci a umožní ti probíranou látkou procházet vlastním tempem. Umožní ti vyměňovat
si matematické postupy a řešení příkladů se svými profesory, spolužáky a širokou komunitou
uživatelů GeoGebry na internetu. Své příklady a kontrukce se později naučíš animovat a dívat se na
ně pod různými pohledy. Připraví tě na další a výkonější matematické programy, bez kterých se
v pozdějším studiu na vysoké škole již neobejdeš.
Co je GeoGebra?
Volně šiřitelný matematický program určený především pro studenty středních škol. Jeho
historie sahá do USA, pokud tě zajímají podrobnosti najdeš je na strákách www.geogebra.org.
Jak si Geogebru nainstaluji na svůj počítač?
Instalace GeoGebry je velice jednoduchá. Stačí si ze školního serveru nebo přímo ze stránek
školy stáhout instalační balíček, který po spuštění vykoná veškerou práci za tebe. K chodu
programu je nezbytné mít na svém počítači nainstalovanou Javu, většina počítačů ji má již
nainstalovanou od svého prodejce, kdyby tvůj počítač Javu neměl. Stáhni si instalační soubor
ze školního serveru nebo přímo od výrobce firmy Oracle, www.oracle.com .Postup práce
při instalaci Javy je podobně jednoduchý.
Ikona GeoGebry na ploše vypadá takto:
Musím mít GeoGebru nainstalovanou na svém počítači, abych s ní
mohl(-a) pracovat?
Nemusíš, GeoGebra běží i bez instalace, pokud je tvůj počítač trvale připojen k internetu
můžeš v prostředí Geogbry pracovat přímo na stránkách www.geogebr.org , musíš jen kliknout na
okno pro práci on-line.
Představení GeoGebry
Co uvidíš po spuštění GeoGebry na svém počítači?
Uvidíš okno, které je velmi podobné oknům, ve kterých se otevírají pracovní programy na
tvém počítači. Nástroje, které vidíš fungují podobně, tak jak od podobných programů očekáváme.
V horní části okna je hlavní menu, pod ním jednotlivé panely nástrojů. Drobný text napravo
od panelu nástrojů obsahuje zkratkovitě nápovědu k nástroji, který je právě vybrán. V levé
střednín části je algebraické okno, vedle něj největší část plochy zaujímá nákresna a v dolní části
okna, kde se obvykle nachází stavový řádek je vstupní řádek. Asi toho vidíš víc, ale pro začátek si
zapamatuj názvy jednotlivých částí okna. Podrobně se k nim vrátíme v dalším textu.
Mohu si teď vyzkoušet jak GeoGebra funguje?
Můžeš, stačí do Vstupního řádku napsat například 1 + 1 a stisknout klávesu Enter.
Na obrazovce zdánlivě nevidíme nic. Vstupní řádek se vyprázdnil. Při podrobnějším
pohledu uvidíme změnu v algebraickém okně. Do něj byl přidán nový volný objekt a = 2. Je jasné,
že náš příklad byl vyřešen a jeho výsledek byl uložen do proměnné jménem a. Podobně snadno
bude vypočítán další z tvých byť sebesložitějších číselných výrazů.
Zatím jenom zkoušíme popsat pracovní prostředí a tak se pokusíme vytvořit nějaký
geometrický objekt. Vybereme si pracovní
nástroj
nový
bod
a
klikneme
do nákresny.Uvidíte podobný obrázek:
Tentokrát je změna patrná vidíme nový bod jehož jméno je A. Při podrobnějším pohledu
vidíme změnu i uvnitř Algebraického okna. Zde je nový volný objekt jménem A. Za jménem
objektu vidíme závorku s dvojicí čísel, které jsou zřejmě souřadnicemi našeho nového bodu.
Všimneme si malé změny od námi navyklého způsobu psaní souřadnic jsou zde souřadnice namísto
hranatých závorek [.,.] uvedeny v závorkách kulatých (.,.).
Mohu si svoji práci uložit?
Stejně jako u jiných typů programů přes hlavní menu Soubor → Uložit nalezneš složku,
do které svoji práci budeš ukládat. Standartní přípona souborů je .ggb a zobrazení pomocí ikony již
znáš z instalace GeoGebry.
Mám GeoGebru stále v angličtině, co mám dělat?
Do českého rozhranní se dostaneš snadno. V hlavní nabídce zvolíš Options → Language →
A-C→ → Czech. Prostředí se automaticky „překlopí“ do češtiny.Viz obrázek níže.
Vidíte, že nabídka jazykového prostředí je bohatá a každý z vás si může navolit jazykovou
mutaci, která mu bude nejlépe vyhovovat.
Opravdový začátek.
Kde mám začít a jak porozumím práci v GeoGebře?
Nejdůležitější částí okna, které ti GeoGebra nabízí, je ta nejmenší část, která se nazývá
Vstupní řádek. Tady ho uvidíš. Najdeš ho ve spodní části okna, tem kde jinde obvykle bývá stavový
řádek.
Je to tvé nové okno do světa matematiky. Budeš pomocí něj a několika jednoduchých
příkazů vytvářet jednoduché nebo složitější matematické objekty. Pod pojmem objekt si můžeš
předtsavit výraz, řešení rovnice, konstrukci kruhu … psaní textu. Hned si ukážeme jak je vstupní
řádek dobrý.
Jak provedu jednoduché matematické operace?
Každý začátek je těžký. Zkusíme pro jednoduchost pomocí vstupního řádku vypočítat
hodnotu jednoduchého číselného výrazu 1 + 2.
Otevři si nový soubor v GeoGebře a do vstupního řádku napiš příklad, který chceš vypočítat 1+2 a
stiskni klávesu Enter. Uvidíš následující obrazovku.
Vstupní řádek na první pohled náš příklad „odmítl“ vypočítat. Opravdu pouze na první
pohled, ve skutečnosti příklad zvládl a dokonce nám výsledek vypsal na obrazovku. při
podrobnějším zkoumání ho uvidíš v levé části okna GeoGebry. Tato část se nazývá Algebraické
okno a slouží k zaznamenání všeho co se v GeoGebře pokusíš vypočítat, sestrojit, vyřešit a zapsat.
Pro větší názornost si Algebraické okno s výpisem výpočtu ukážeme.
Výsledek je v něm zapsán do proměnné a . Hodnota proměnné a je rovna číslu 3. Pokud
Algebraické okno nevidíš, tak si ho jednoduše zobrazíš Zobrazit → Algebraické okno. Podobně
jednoduše vypočítáš podobné numerické výrazy. Geogebra pracuje podobně jako tvůj kapesní
kalkulátor a v jejím užití není žádný rozdíl. Pamatuj, že výsledek je vždy zapsán do určité
proměnné, pokud nezvolíš jinak, budou jména přidělována v abecedním pořadí jako jednotlivá
písmena.
Co je to proměnná a jaký význam má její jméno?
Nehledej žádnou složitou definici, je to pouze místo v paměti, do kterého se ukládá číslo
nebo text, který je zapsán do vstupního řádku. Označení musí být jednoznačné. Nemůžeme jedním
písmenem nebo slovem v jednom souboru označit dvě různé číselné hodnoty. Je dobré si uvědomit,
že jméno, které je přidělováno proměnné mohu sám ovlivnit a tím si zjednodušit výpočet určitých
typů příkladů. V názvu proměnné nedělej mezeru, nepoužívej diakritická znaménka. Nevymýšlej
krkolomná jména typu p!?* . Některá slova jsou vyhrazena pro příkazy GeoGebry opět to znamená,
že takové slovo nelze použít. Takové slovo poznáš snadno, ve Vstupním řádku se ti ho GeoGebra
bude snažit vnutit sama. Většinou takové slovo končí () nebo []. Nedej se odratit ve skutečnosti je
zápis i čtení výpočtu velice jednoduché! Podívej se na řešení následujícího příkladu.
Vypočítej obsah obdélníku o délce 5 cm a šířce 3 cm.
Nejjednodušší způsob je do Vstupního řádku napsat součin 5*3 výsledek v GeoGebře
vypadá následujícím způsobem:
Výsledek sice vidíme, ale o samotném výpočtu ani zadání úlohy se nedozvíme nic.
Pokud budete chtít zapsat desetinné číslo, musíte počítat s tím, že v anglo-americkém formátování
čísel se místo desetinné čárky používá desetinná tečka. Číslo např. 3,67 zapíšete takto: 3.67.
Lepší postup, který nás bude stát o něco více námahy je následující. Zavedeme proměnné a,
b. Do vstupní řádku na píšeme a = 5 a stiskneme Enter, b = 3 a stiskneme Enter. Pro výpočet
obsahu obdélníku zvolíme známý vzorec S = a*b. Tak jak vzorec vidíte ho přepíšete do vstupního
řádku a stisknete klávesu Enter. Výsledek v algebraickém okně má následující podobu:
Vidíme zadané hodnoty pro délku a šířku obdélníku a výsledek. Vidíme, že obsah S je
zaznamenán mezi závislými objekty. Je jasné proč tomu tak je?
Tentokrát by pro nás bylo snazší si domyslet co v Algebraickém okně máme zaznamenáno,
ale budeme to vědět zítra nebo pozítří?
Pro tyto situace existuje ještě lepší řešení následujícího typu.
Do vstupní řádku napíšeme delkaObdelniku = 5 a stiskneme Enter, sirkaObdelniku = 3
a stiskneme Enter a obsahObdelniku = delkaObdelniku*sirkaObdelniku. Výsledek v GeoGebře
vypadá následujícím způsobem:
Celý výpočet uložíme jako soubor obsahObdelniku.ggb.
Jaké to má výhody? Jen byl celý postup několikrát delší.
Celý postup je delší, ale z hlediska trvalé hodnoty má podstatné výhody. Vidíme zápis
příkladu, vidíme s čím jsem počítal a co jsem počítal. Pokud se změní zadání úlohy stačí jednoduše
poklepat na volný objekt a jeho hodnotu zadat znovu (například sirkuObdelniku). Celý výpočet
obsahu bude automaticky přepočítán. Pokud poklepete na závislý objekt (obsahObdelniku) uvidíte
jakým způsobem byl vypočítán. U složitějších příkladů můžete provádět opravu výrazu jakým byl
vypočítán.
Uvědomte si souvislost mezi volným objektem a nezávislou proměnnou a závislým objektem a
závislou proměnnou.
Sami zkuste postup zoopakovat pro výpočet obsahu čtverce.
Už je to lepší. Nelíbí se mi způsob zápisu výsledku. Je možné ho zapsat jinak
přehledněji?
Je to možné a stojí to jen pár sekund práce navíc. Výsledek bude zapsán v Nákresně, to je to
největší okno GeoGebry, které před sebou vidíte uprostřed stránky. Obvykle se nákresna používá i k
vykreslování matematických objektů, proto jsou v ní osy a mřížka. Ty teď nebudeme potřebovat
a tak je skryjeme pomocí hlavní nabídky Zobrazit → Mřížka nebo Zobrazit → Osy.
Do Vstupního řádku napíšeme Text a potvrdíme z nabídky nápovědy příkaz Text [<Objekt>].
„Slovo“ <Objekt> nahradíme následujícím textem i s uvozovkami "Obsah obdélníku je " +
obsahObdelniku poté stiskneme Enter. Výsledek má přibližně následující podobu:
Máme vypočítaný celý příklad, máme zapsané zadání a máme i odpověď.
Vstupní řádek se podobá svými funkcemi kalkulačce? Je možné najít
některé konstanty nebo funkce podobně jako na kalkulačce?
Opravdu je vstupní řádek a práce s ním podobná práci na kalkulačce. Klávesnice je
klávesnice tvého počítače. Vstupní řádek a Algebraické okno jsou displejem tvé nové kalkulačky.
Podobně jako ve tvé kalkulačce je i ve vstupním řádku připravená řada matematických funkcí
a konstant. Jejich pojmenování je obdobné nebo stejné jako na tvé kalkulačce a odpovídá
mezinárodnímu standartu. Navíc máš k dispozici různé matematické konstanty. Jednou z nejčastěji
používaných je číslo π. Do vstupního řádku jej zadáš jednoduše. Klikneš k pravému okraji řádku.
Poté se objeví nabídka matematických symbolů , které můžeš jednoduše do řádku vkládat kliknutím
na tlačítko α. Zde je ilustrační obrázek:
Z nabídky vybereš požadovanou konstantu.
Celý postup si ještě jednou zopakujeme na výpočtu obsahu kruhu. Vypočítej obsah kruhu o
poloměru 6 cm.
Zavedeme si proměnnou polomerKruhu a dosadíme do ní hodnotu 6. Potom vypočítáme
obsah kruhu tak, že do proměnné obsahKruhu uložíme výsledek výpočtu π*polomerKruhu^2.
Přitom si π načteme z nabídky symbolů na konci Vstupního řádku. Pro ilustraci nabízím záznam
výpočtu. A odkaz na výsledný soubor obsahKruhu.ggb. (Symbol ^ jistě znáte ze své kalkulačky.
Do vstupního řádku ho nejjednodušeji zapíšete tak, že podržíte levou klávesu Alt za současného
napsání číslené kombinace 94 na vaší numerické klávesnici)
Existuje nějaký seznam matematických funkcí, které lze zadat do
vstupního řádku?
Existuje, kompletní seznam najdeš v nápovědě hlavního menu. Tady je krátký seznam operací
a operátorů, které jsou třeba k nejběžnějším činnostem vstupního řádku.
Předdefinované operace a
operátory vstupního řádku
Operace
Vstupní řádek
Součet
Rozdíl
Součin
Podíl
Umocňování
Faktoriál
Závorky
x-ová souřadnice
y-ová souřadnice
Absolutní hodnota
Druhá odmocnina
Třetí odmocnina
Náhodné číslo mezi 0 a 1
Exponenciální funkce
Logaritmus (přirozený a
dekadický)
Logaritmus o základu 2
Logaritmus o základu 10
Logaritmus x o základu b
Kosinus
Sinus
Tangens
Kotangens
Arkus kosinus
Arkus sinus
Arkus tangens
+
* nebo mezerník
/
^ nebo 2 v horním iondexu
!
()
x( )
y( )
abs( )
sqrt( )
cbrt( )
random( )
exp( ) or ℯx
ln( ) or log( )
ld( )
lg( )
log(b, x )
cos( )
sin( )
tan( )
cot()
acos( ) or arccos( )
asin( ) or arcsin( )
atan( ) or arctan( )
Je možné měnit u výsledku, který jsem získal z GeoGebry počet
zobrazených desetinných míst?
Je to možné pomocí následující posloupnosti kroků si můžeš nechat zobrazit číslo v téměř
libovolném rozsahu. Nastavení → Zaokrouhlování.
Obvykle programy obsahují tzv. klávesové zkratky, které urychlují práci
v programu. Má je i GeoGebra?
Ano má pojďme se na některé z nich podívat.
Nejprve zkratky pro psaní řeckých písmen a symbolů. Připomeňme si význam písmene jako vnitřní
konstanty, která obsahuje požadovanou hodnotu Ludolfova čísla.
KLÁVESOVÉ ZKRATKY
ZNAK
A
B
D
E
F
G
I
KOMBINACE
Alt + A
Alt + B
Alt + D
Alt + E
Alt + F
Alt + G
Alt + I
L
M
O
Alt + L
Alt + M
Alt + O
P
Alt + P
S
T
Alt + S
Alt + T
HODNOTA
alpha α
beta β
delta δ
Eulerovo ℯ
phi φ
gamma γ
imaginární jednotka
ί = √-1
lambda λ
mu μ
symbol ° (min,
max, increment)
pi π (min, max,
increment)
sigma σ
theta θ
Klávesové zkratky pro některé často používané operace v GeoGebře:
KLÁVESOVÉ ZKRATKY
ZNAK
A
A
C
C
KOMBINACE
Ctrl + A
Ctrl + Shift + A
Ctrl + C
Ctrl + Alt + C
Ctrl + Shift + C
C
E
L
N
O
P
Q
Ctrl + E
Ctrl + Shift + L
Ctrl + N
Ctrl + O
Ctrl + P
Ctrl + R
R
S
S
V
Y
Z
0
1
2
2
3
4
5
6
7
8
9
Ctrl + S
Ctrl + Shift + S
Ctrl + V
Ctrl + Y
Ctrl + Z
Alt + 0
Alt + 1
Ctrl + 2
Alt + 2
Alt + 3
Alt + 4
Alt + 5
Alt + 6
Alt + 7
Alt + 8
Alt + 9
OPERACE
Select All
Zobrazit / Skrýt
Algebraické okno
kopírovat
kopírovat hodnoty
z tabulky
Kopírovat z
grafického okna do
schránky
Otevřít vlastnosti
Zobrazit/Skrýt
Postup konstrukce
Nové okno
Open
Tisk
Ukončit GeoGebru
Přepočítej vše
(včetně náhodných
čísel)
Uložit
Zobrazit tabulku
Vložit
Dopředu
Zpět
umocni na 0
umocni na 1
Zvětšit
umocni na 2
umocni na 3
umocni na 4
umocni na 5
umocni na 6
umocni na 7
umocni na 8
umocni na 9
Jak se v GeoGebře zobrazují čísla. Jsou vždy zaokrouhlena na dvě
desetinná místa?
GeoGebra pokytuje celou řadu nástrojů, kterými můžeš ovlivnit zobrazení zadaného čísla
nebo výsledku. Najdeš je v hlavní nabídce. Například budeme chtít zobrazit číslo zaokrouhlené
na jedno desetinné místo. Pak postupně zvolíme následující nabídky Nastavení → Zaokrouhlování
→ 1 desetinné místo. Viz obrázek
Jak v GeoGebře zapsat velmi malá nebo naopak velmi velká čísla?
Pro zápis takovýchto čísel se obvykle používá tzv. vědeckého tvaru zápisu čísla. Například
číslo 1 010 000 zapíšeme takto 1.01E6. Číslo 0,000 12 zapíšeme jako 1.2E-4. Podobně
s takovýmito čísly zachází tvoje kalklačka.
Závěrečné příklady k procvičení.
Příklad č. 1
1
+0,25.3
8
Vypočítej hodnotu výrazu
.
1
4−2
3
Postup: celé řešení spočívá ve správném přepisu výrazu do vstupního řádku. Čitatele i jmenovatele
utavřeme do závorek, a závorky dále použijeme i pro přepis smíšeného zlomku.Operaci násobení
zapisujeme operátorem *, operaci dělení operátorem /, desetinné číslo píšeme místo čárky s tečkou.
Výsledek je zapsán v algebraickém okně a uložen do proměnné a. Vidíme to na výpisu
algebraického okna.
Přesnost s jakou je výsledek zobrazen je nastavena v typu zaokrouhlování. My máme
nastavenu implicitní přesnost 2 desetinná místa.
Pokusíme se výsledek zapsat do Nákresny. Využijeme k tomu vstupní řádek a příkaz Text.
Do jeho složených závorek napíšeme "Hodnota výrazu zaokrouhlená na 2 desetinná místa je:
" + a. Nákresna bude mít následující vzhled.
Pokud chceme zobrazit přesnou hodnotu výrazu ve varu zlomku, využijeme k tomu příkaz
ZlomekText. Ten naší proměnnou na obrazovce vypíše ve tvaru zlomku. Takto vypdá vstupní řádek
s užitím tohoto příkazu.
Takto výpis do nákresny.
Do Nákresny vložíme ještě jedno textové pole s obsahem: "Přesná hodnota výrazu je: ". Textová
pole v Nákresně logicky seřadíme do tvaru:
Vyřešený příklad je ke stažení zde Příklad č 1.ggb.
KONEC
Příklad č. 2
Vypočítej velikost úhlu α v pravoúhlém trojúhelníku,je-li velikost stany a = 4,2 cm a velikost
přepony c = 7,8 cm. Výsledek zaokrouhli na dvě desetinná místa.
Postup: Do nového souboru v GeoGebře načteme hodnoty pro proměnné a = 4.2 a c = 7.8 (pozor
a
na destinnou tečku). Výpočet úhlu α provedeme pomocí definice sin α =
, takže
c
a
α =sin−1( ) . Funkci sin -1 nazýváme arkus sinus v GeoGebře pro ni máme příkaz asin(). Zápis
c
ve vstupním řádku bude mít následující tvar:
Po stisku klávesy Enter je Algebraickém okně následující zápis:
Vidíme, že úhel α je vyjádřen v radiánech. Pokud je požadován převod velikosti úhlu na
stupně, doplníme do Vstupního řádku přepočet, který pro přehlednost načteme do proměnné
αstupne. Vzhled Vstupního řádku je následující:
Po stisku klávesy Enter vypadá Algebraické okno takto:
Zbývá do Nákresny vložit odpověď. Tu umístíme do textového pole pomocí Vstupního
řádku a funkce Text[ ]. Celý zápis ve Vstupním okně má následující tvar: Text [" Velikost úhlu α
v radiánech je: " + α + " a stejného úhlu ve stupních " + αstupne+"°."].
Výsledný text v Nákresně má následující tvar:
Poznámka: Vyzkoušej si další možnosti, které ti nabízí GeoGebra. V Algebraickém okně klikni na prázdné kolečko
u proměnné a. V nákresně se objeví posuvník se jménem proměnné a. Posuvníkem můžeš měnit hodnotu proměnné a
zároveň výsledek výpočtu.
Celý příklad si můžete prohlédnout zde: Příklad č 2.
KONEC
Příklad č. 3
Je již celý zadán v GeoGebře. Náhled zadání vidíte níže. Zkuste si jej vyřešit sami. Odkaz na
vyřešený příklad v GeoGebře naleznete zde Příklad č 3.
Příklad č. 4
3a 2−4,2 a+1,6
, pro a=1 ; 3 ;−1 ; 2,5 .
Urči hodnotu výrazu
a 2+1,8
Postup: V novém souboru si vytvoříme proměnnou a, do které načteme první hodnotu a = 1. Potom
vytvoříme novou proměnnou nazvanou hodnotaVyrazu do které vložíme výraz ze zadání příkladu:
(3a2-4.2+1.6)/(a2+1.8). Entrem potvrdíme zadání výrazu. Pro zadání dalších hodnot proměnné a
klikneme na prázdné kolečko v Algebraickém okně u proměnné a a posuvníkem v Nákresně
měníme hodnotu proměnné a. Zároveň odečítáme nové hodnoty výsledného výrazu uložené v
hodnotěVýrazu.
Celý příklad si můžete prohlédnout zde: Příklad č 4.
KONEC
Download

Úvodní práce v Geogebře