Nexus u mreži korisnika
1
Logotip
sponzora
Nexus u mreži korisnika
Krešimir Trobić
Nexus u mreži korisnika
2
Sadržaj
Potrebe modernog data centra
Pregled Nexus serije proizvoda
Koraci do odabira rješenja
Primjeri konfiguracije
Nexus u mreži korisnika
3
Potrebe modernog
data centra
Nexus u mreži korisnika
4
Dosadašnji data centri
Neki od izazova u današnjim data centrima
Odvojena mreža za ethernet i storage
Kabliranje za svaku pojedinu mrežu
Problemi sa skalabilnošću
Viši troškovi
Implementacije i održavanja
Nexus u mreži korisnika
5
Dosadašnji data centri
Neki od izazova u današnjim data centrima
Veća gustoća servera sa više procesora/jezgri i
memorije po jedinici površine
Potrebno je puno više I/O kapaciteta po serveru
Veliki broj mrežnih uređaja za konfiguraciju i održavanje
Prevladavajuća tehnologija unutar data centra je
ethernet
Nexus u mreži korisnika
6
Novi data centri
Proširenje data centra
Konsolidacija resursa i štednja energije
Virtualizacija
Smanjenje troškova održavanja
Objedinjavanje LAN i SAN mreže na FCoE
Povećanje propusnosti i malo unošenje kašnjenja kod
preklapanja (latencija)
Povezivanje servera na 10 GE
Potrebna je implementacija ethernet-a bez gubitaka
zbog prirode FC prometa koji ne podnosi gubitke
Nexus u mreži korisnika
7
Fibre channel over Ethernet
Zahtjeva 10 GE
Zahtjeva Ethernet bez gubitaka
Odgovara ponašanju FC-a
koji nema gubitaka (lossless)
Zahtjeva Ethernet jumbo frames
Fibre channel okvir ima maksimalno 2148 byta
(zaglavlje+podatci)
Nexus u mreži korisnika
8
Nexus portfolio
Nexus u mreži korisnika
9
Pregled Nexus serije proizvoda
Nexus 7000
Modularni preklopnik visoke propusnosti za
velike data centre
Nexus 5000
10 GE/FCoE preklopnik za data centar
ethernet
Nexus 2000 Fabric Extender
Omogućava Nexus-u dodatne gigabit
ethernet portove
Nexus 4000 Blade preklopnik
10 GE/FCoE preklopnik za blade poslužitelje
Nexus 1000V
Softverski preklopnik za virtualnu okolinu
VM
Adapteri
CNA (Converged Network Adapters) –
Ethernet i FCoE
Nexus u mreži korisnika
10
Nexus 7000
Modularna arhitektura predviđena za 15 Tb/s
propusnosti
In-service zamjena softvera bez prekida u radu
Virtual device contexts (VDC)
Pripremljena arhitektura za 40GE / 100GE brzine
Dva modela sa 10 i 18 modula
Model sa 10 modula
256 10 GE portova ili 384 GE portova unutar jednog sustava
480 Mpps
Model sa 18 modula
512 10 GE portova ili 768 GE portova unutar jednog sustava
960 Mpps
Nexus u mreži korisnika
11
Nexus 5000
Preklopnik za access dio data centra
Arhitektura za 1 Tb/s propusnosti
Dva modela 5010 i 5020 do 28 i 56 portova
5020 model
40 fiksnih 10 GE portova – Ethernet i FCoE
Prvih 16 portova omogućava 1 GE i 10 GE
2 utora za proširenje kapaciteta (FC, FC+Ethernet, Ethernet)
5010 model
20 fiksnih 10 GE portova – Ethernet i FCoE
Prvih 8 portova omogućava 1 GE i 10 GE
1 utor za proširenje kapaciteta (FC, FC+Ethernet, Ethernet)
Nexus u mreži korisnika
12
Nexus 4000
Cisco Nexus switch modul za IBM BladeCenter
10 GE Ethernet i FCoE
NX-OS
6 x 10GE uplink prema ostatku mreže
14 x 10 GE prema blade serverima
400 Gb/s brzina preklapanja
300 mpps
Nexus u mreži korisnika
13
Nexus 2000
Fabric extender (FEX) za Nexus 5000
Služi kao udaljeni linecard na Nexusu 5000 na kojem
se vrši cjelokupna konfiguracija
48 x 1GE – prema serverima unutar rack-a
4 x 10 GE uplink prema Nexus 5000 preklopniku
(SFP+)
Moguće je spajanje 12 FEX na jedan Nexus 5000
Moguće je spajanje na više nadređenih Nexus 5000
preklopnika koristeći virtual PortChannel (vPC)
tehnologiju
Nexus u mreži korisnika
14
Nexus 1000
Preklopnik unutar VMware vSphere virtualne okoline
Policy-Based veza prema virtualnim serverima,
povećana sigurnost
Povećana produktivnost i fleksibilnost u radu
Ista radna okolina kao i na ostalim Nexus proizvodima
Korištenjem vMotiona sve mrežne postavke se sele na
novo okruženje
Nexus u mreži korisnika
15
Odabir rješenja
Nexus u mreži korisnika
16
Odabir rješenja – Nexus 5000
Podržava 1 Gb/s i 10 Gb/s SFP portove
Omogućava potpunu Fibre Channel over Ethernet
(FCoE) podršku
2G, 4G i 8 G FC verzije
Licenciranje putem unošenja komande
Omogućuje kreiranje više uloga nadležnosti nad
sistemom
Nexus u mreži korisnika
17
Odabir rješenja – Nexus 2000
Nexus 2000 kombinira prednosti ToR i EoR
arhitektura
Fizički se nalazi na vrhu ormara (top of rack)
Logički se ponaša kao end-of-row pristupni uređaj
Implementacija Nexus-a 2000
Smanjuje dužinu mrežnih kablova
Smanjuje broj točaka potrebnih za konfiguraciju
Omogućava da Nexus-u 5000 postane pristupni preklopnik sa
velikim brojem gigabitnih priključaka
Zaštita dosadašnjih ulaganja
VN-Link mogućnosti
Nexus u mreži korisnika
18
Odabir rješenja – Nexus 1000
Omogućava jasnije razgraničenje između mrežnih i
serverskih nadležnosti
Dodatne funkcionalnosti na virtualnom portu: ERSPAN,
Netflow, port statistics
Security-VLAN, ACL, DHCP Snooping, port security,
Dynamic ARP Inspection
Fine tunning – QoS
HA – LACP, vPC host mode
Nexus u mreži korisnika
19
ROI Analiza Nexus modela
Nexus 1000v ROI Spreadsheet
https://www.myciscocommunity.com/docs/DOC-11123
Cisco Nexus 5000 Unified Fabric TCO Calculator
http://www.simplifymydc.com/assets/5899
Nexus u mreži korisnika
20
Implementacija Nexusa u mrežu
Ostatak
mreže
LAN
SAN
Jedna mgm
domena
Nexus
5000
2148T
2148T
5010
1GE
Ormar
1GE
Ormar
10GE
Ormar
Nexus u mreži korisnika
Blade
Chassis
10GE
10G/
DCE/
FCoE
Blade
Chassis
10GE
21
Primjeri konfiguracije
Nexus u mreži korisnika
22
Nexus Ethernet i FCoE konfiguracija
switch(config)# interface ethernet 1/4
switch(config-if)# spanning-tree port type edge trunk
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk allowed vlan 1,200
switch(config)# interface vfc 4
switch(config-if)# bind interface ethernet 1/4
switch(config)# vlan 200
switch(config-vlan)# fcoe vsan 2
switch(config)# vsan database
switch(config-vsan)# vsan 2 interface vfc 4
Nexus u mreži korisnika
23
Nexus FEX konfiguracija
fex 100
pinning max-links 1
description First_Nexus_2148T
interface port-channel100
switchport mode fex-fabric
fex associate 100
interface Ethernet1/19
switchport mode fex-fabric
fex associate 100
channel-group 100
interface Ethernet1/20
switchport mode fex-fabric
fex associate 100
channel-group 100
Nexus u mreži korisnika
24
Nexus vPC konfiguracija
int mgmt 0
ip address 192.168.0.10/24
vrf context management
ip route 0.0.0.0/0 192.168.0.1
feature vpc
feature lacp
vlan 101
vpc domain 1
peer-keepalive destination 192.168.0.2
int ethernet 1/17-18
channel-group 1 mode active
int po1
vpc peer-link
switchport mode trunk
switchport trunk allowed vlan 1,101
Nexus u mreži korisnika
25
Nexus vPC konfiguracija
fex 100
pinning max-links 1
int e1/9-10
channel-group 100
int po100
switchport mode fex-fabric
fex associate 100
int ethernet 100/1/1
channel-group 10
int po10
vpc 10
switchport access vlan 101
Nexus u mreži korisnika
26
Nexus QoS konfiguracija
System Policy - primjer
switch(config)# system
switch(config-system)# service-policy dc-policy
switch(config)# policy-map dc-policy
class eth-lo
mtu 9000
class eth-hi
pause no-drop
mtu 1500
class dc-control
mtu 4000
switch(config)#class-map eth-lo
match cos 2
class-map eth-hi
match cos 4
class-map dc-control
match cos 5
Nexus u mreži korisnika
27
Nexus QoS konfiguracija
Standardno na preklopniku postoje 4 klase:
FC-default
bez gubitaka paketa (no drop), FC i FCoE promet automatski
upada u ovu klasu
Sup-hi – visokoprioritetni “control plane” promet (BPDU, FSPF)
Sup-low – niskoprioritetni “control plane” promet (CDP, itd.)
Eth-default – svi ostali prometi su klasificirani u ovu klasu
sa mogućnošću gubitka paketa (Drop) (best effort class)
korisnik ne može izbrisati sistemske klase:Sup-HI, Sup-Low and
FC-default
korisnik može modificirati parametre u FC-default klasi, ali ne u Sup
klasama
korisnik može definirati 5 novih sistemskih klasa
uključujući i Ethernet class-default
Nexus u mreži korisnika
28
Nexus QoS konfiguracija
Priority Flow Control
Omogućava preklapanje okvira bez gubitaka za sve klase prometa
PAUSE mehanizam se aktivira prema prioritetima kada se iskoriste
svi krediti u međuspremniku
Nexus u mreži korisnika
29
Nexus 1000v
Preklopnik se sastoji iz dva dijela: VSM i VEM
VSM – Virtual Supervisor Modul – osigurava nadzor, konfiguraciju i
upravljanje virtualnog preklopnika (VEM-a) (control plane)
VEM – Virtual Ethernet Modul – omogućava napredne mrežne
funkcionalnosti na hypervisoru (data plane)
Za konfiguraciju su potrebna minimalno 4 VLAN-a:
Management VLAN – kojim se spajamo na VSM i konfiguriramo sustav
Control VLAN – Razmjena kontrolnih informacija sa VEM-ovima
Packet VLAN – Razmjena posebnih data informacija poput CDP-a i sl.
Data VLAN-ovi – Vlan-ovi koji prenose korisničke podatke (VSM ne
treba imati pristup ovim vlan-ovima)
Nexus u mreži korisnika
30
Nexus 1000v
Uplink port-profili – služe za spajanje vmware host-a (VEM) sa
vanjskom mrežom
port-profile uplink_port_profile_1
capability uplink
vmware port-group
switchport trunk allowed vlan 10-14,21-22
no shutdown
system vlan 10-11,21-22
state enabled
VM port-profili – služe za spajanje virtualnih host-ova
port-profile vmnetwork-106
vmware port-group
switchport mode access
switchport access vlan 106
no shutdown
state enabled
Nexus u mreži korisnika
31
Hvala!
[email protected]
Nexus u mreži korisnika
32
Download

Cisco Nexus u mreži korisnika