Microsoft Excel 2007
Ders Notu
Öğr. Gör. Mustafa YAVAŞ
www.mustafayavas.org
Öğr.Gör. Mustafa YAVAŞ [email protected]
1
EXCEL
- Elektronik tablolama veya hesaplama programı olarak da
adlandırılan Excel, girilen veriler üzerinde hesap yapabilme,
tablolar içinde verilerle grafik oluşturma, verileri karşılaştırıp
sonuç üretebilme özellikleriyle, en çok kullanılan hesaplama
programıdır.
Öğr.Gör. Mustafa YAVAŞ [email protected]
2
EXCEL’le yapabilecekleriniz
Matematiksel işlemler (4 işlem)
2. Mantıksal karşılaştırma işlemleri (>,>=,<,<= gibi)
3. Fonksiyonlar (Metin,tarih, matematiksel fonksiyonlar) mod,
tanjant, kotanjant
4. Grafik işlemleri
5. Tablo oluşturma işlemleri
1.
Öğr.Gör. Mustafa YAVAŞ [email protected]
3
EXCEL’de hücrelere hangi bilgiler girilebilir?
1.
2.
3.
4.
Metin
Rakam
Tarih ve Saat
Formül
Öğr.Gör. Mustafa YAVAŞ [email protected]
4
EXCEL’de FORMÜL OLUŞTURMA

Excel’de formül oluştururken şu kurallara uymak
gerekir:
1.
Bütün formüller Eşittir(=) işareti ile başlar.
Sadece 2 hücre arasında işlem yapılacaksa, hücrelerin
adresleri arasına Noktalı Virgül(;) koyulur. (örn,
=topla(A2;B2))
Formül içerisinde boşluk kullanılmaz.
=topla(A2;B2) doğru , =topla (A2;B2) yanlış
2.
3.
Öğr.Gör. Mustafa YAVAŞ [email protected]
5
EXCEL’de FORMÜL OLUŞTURMA
4. İki hücre arasında kalan hücrelerle ilgili işlem yapılacaksa,
hücrelerin adresleri arasına (:) koyulur.
Örn, topla(A2:A10)
5. Bir rakamın veya hücrenin belirli bir yüzdesini hesaplatmak
için % işareti kullanılır.
Örn, A5 hücresindeki rakamın %18’ini hesaplamak için şu
formül yazılır:
=A5*18%
Öğr.Gör. Mustafa YAVAŞ [email protected]
6
EXCEL’de FORMÜL OLUŞTURMA
6. Matematiksel işlemlerde işlem önceliği aşağıdaki şekildedir :
Yüzde, üs alma, çarpma-bölme, toplama-çıkarma
Örn; 3+18/3 işleminde önce 18/3 işlemi yapılır. Sonra çıkan
sonuç 3 ile toplanır.
Yani sonuç : 3+6=9’dur.
Öğr.Gör. Mustafa YAVAŞ [email protected]
7
EXCEL’de FORMÜL OLUŞTURMA
7. Önceliği eşit olan işlemlerde, işlem önceliği sol tarafta yer alan
işlemdedir.
Örn; 130/13*2 formülünde çarpma ile bölme aynı işlem
önceliğine sahip olduğundan önce sol taraftaki işlem (bölme)
yapılır.
Sonuç: 10*2 = 20
8. Bir formüldeki matematiksel işlemlerde önce parantez
içerisindeki işlemler, sonra parantez dışındaki işlemler yapılır.
Öğr.Gör. Mustafa YAVAŞ [email protected]
8
EXCEL’de FORMÜL OLUŞTURMA
Örnek: (5+4)*3 işleminin sonucu
9*3=27’dir.
10. Bir formülde açılan parantezlerin gerektiği yerde kapatılması
gerekir.Yoksa hata mesajı verir.
9.
11. Hücreye ondalık rakam (10.11) yazıp Enter’a bastıktan sonra,
yazılan sayı tarih biçimine dönüşebilir. Bu durumda hücrenin
biçimlendirilmesi gerekir. Peki nasıl hücreyi biçimlendiririz ?
Öğr.Gör. Mustafa YAVAŞ [email protected]
9
EXCEL’de FORMÜL OLUŞTURMA
12. Metin bulunan hücrelerdeki metinleri birleştirmek için,
eşittir(=) işaretinden sonra ilk hücrenin adresini yazınız ve &
işaretinden sonra diğer hücrenin adresini yazınız. =A2&A3
13. Metin bulunan hücrelerdeki metinleri, aralarında boşluk
bırakarak birleştirmek için şu formülü yazarız:
=A2&" "&B3&" "&C1
Öğr.Gör. Mustafa YAVAŞ [email protected]
10
EXCEL’de FORMÜL OLUŞTURMA
14. Formüllerde sayısal metinler kullanarak işlemler yapabiliriz.
(örn, 10 YTL + 20 YTL …)
15. Formüllerde metinsel ifadeler tırnak içinde yazılır. ("kaldı",
"geçti" gibi)
Öğr.Gör. Mustafa YAVAŞ [email protected]
11
EXCEL
Verileri sürükleyerek çoğaltmak.
Sonuç
Öğr.Gör. Mustafa YAVAŞ [email protected]
12
EXCEL (Hücrelerin Seçilmesi)
Yan yana olmayan birden çok satır veya sütunu
seçmek :
-
tuşu basılı iken seçmek istediğimiz satır veya
sütunlara tek tek tıklarız.
CTRL
Öğr.Gör. Mustafa YAVAŞ [email protected]
13
Hücreleri Birleştirmek

Bu işlem için, biçimlendirme araç
çubuğundaki Birleştir ve Ortala düğmesini
kullanırız.
Öğr.Gör. Mustafa YAVAŞ [email protected]
14
Birleştirilmiş hücreleri ayırmak
Hücre üzerinde sağ tıklayın.
 Açılan menüde Hücreleri Biçimlendir –
Hizalama sekmesine tıklayın.
 İşaretli durumda olan Hücreleri Birleştir
seçeneğinin onay işaretini kaldırın.
 Tamam düğmesine basın.

- Kısa yol : Birleştir ve Ortala düğmesine
bir kez daha basın.
Öğr.Gör. Mustafa YAVAŞ [email protected]
15
Hücredeki yazının yönünü değiştirmek
Hücre üzerinde sağ tıklayın.
 Hücreleri biçimlendir komutuna ve Hizalama
sekmesine tıklayın.
 Hizalama bölümünden kırmızı düğmeyi tıklayıp
sürükleyerek, yazıya istediğiniz gibi yön verin.


Tamam düğmesine basın.
Öğr.Gör. Mustafa YAVAŞ [email protected]
16
Hücrede birden çok satır oluşturmak




Yazı yazdığınız hücrede iken farenin sağ düğmesine
tıklayın.
Hücreleri biçimlendir.
Metin denetimi – Metni Kaydır tıklayın.
Tamam düğmesine tıklayın.
Öğr.Gör. Mustafa YAVAŞ [email protected]
17
Hücre eklemek - silmek
Satır eklemek - silmek
Öğr.Gör. Mustafa YAVAŞ [email protected]
18
Fonksiyonlar
Matematiksel İşlemler ve Formül Oluşturmak
1.
Toplama İşlemi
-
Sadece 2 hücre değerini toplayacaksak,
= A2+B2
veya
= TOPLA(A2;B2) formülünü yazarız.
-
Hücre aralığını toplayacaksak,
= TOPLA(A2:A10)
A2 hücresi ile A10 hücresi arasındaki tüm
sayıları toplar.
Öğr.Gör. Mustafa YAVAŞ [email protected]
19
2. Çıkarma
İşlemi
Öğr.Gör. Mustafa YAVAŞ [email protected]
20
3. Çarpma İşlemi

Sadece 2 hücredeki değerin çarpım
sonucunu hesaplatmak istiyorsak,
= A2*B2 formülünü kullanırız.

Hücre aralığındaki tüm değerleri çarpmak
istiyorsak
= ÇARPIM(A2:A6) formülünü yazarız.
(A2 hücresi ile A6 hücresi arasındaki tüm değerleri
çarpar.)
Öğr.Gör. Mustafa YAVAŞ [email protected]
21
4. Bölme İşlemi

İşlem operatörü olarak Bölü ( / ) işareti
kullanılır.
Örnek kullanım;
= A2/B2
(A2 hücresindeki değeri B2 hücresine böler.)
Öğr.Gör. Mustafa YAVAŞ [email protected]
22
5. Ortalama İşlemi

Belirli bir aralıktaki hücrelerin ortalamasını
hesaplamak için kullanılır.
=ORTALAMA(A2:A8) formülü ile
A2 hücresi ile A8 hücresi arasındaki sayıların
ortalaması hesaplanır.
Öğr.Gör. Mustafa YAVAŞ [email protected]
23
6. Yüzde İşlemi
Herhangi bir hücrede belirtilen sayının,
belirtilen oran kadar yüzdesinin
hesaplanmasıdır.
 D3 hücresinin %30’unu hesaplamak için;
= D3*30% formülünü yazarız.

Öğr.Gör. Mustafa YAVAŞ [email protected]
24
7. Karekök fonksiyonu
=KAREKÖK(sayı) formülüyle hesaplanır.
8. Yuvarla fonksiyonu
=YUVARLA(sayı;basamak sayısı) formülüyle
hesaplanır.
Sayı : Hücre içindeki değeri
Basamak sayısı : Virgülden sonraki basamak
Sayısını belirtir.
Örn; YUVARLA(83,59;0)= 84 sonucunu verecektir.
Öğr.Gör. Mustafa YAVAŞ [email protected]
25
9. Tamsayı fonksiyonu
Ondalıklı sayının tam sayı kısmını alan fonksiyondur.
=TAMSAYI(sayı)
= Tamsayı(52,5) işleminin sonucu 52 olacaktır.
10. Mod fonksiyonu
- Bölme işleminde kalanı veren fonksiyondur.
=MOD(Bölünen;Bölen)
Örn; A4 hücresindeki değerin A5 hücresindeki değere
bölündüğünde vereceği kalanı;
=MOD(A4;A5) formülüyle hesaplarız.
Öğr.Gör. Mustafa YAVAŞ [email protected]
26
KARŞILAŞTIRMA FONKSİYONLARI
1. En büyük değer (MAK)
=MAK(A1:D5) formülüyle A1-D5 aralığındaki en
büyük sayı hesaplanır.
Uyarı
- (;) ile (:) işaretine dikkat
2. En küçük değer (MİN)
=MİN(A3:B9) formülüyle A3-B9 aralığındaki en
küçük sayı hesaplanır.
Öğr.Gör. Mustafa YAVAŞ [email protected]
27
KARŞILAŞTIRMA FONKSİYONLARI
3. EĞER FONKSİYONU
=EĞER(ŞART; Sonuç1; Sonuç2)
ŞART : Değerlerin karşılaştırıldığı kısım.
Sonuç1 : Şartın gerçekleşmesi durumunda üretilerek,
hücreye sonuç olarak yazılacak kısım.
Sonuç2 : Şartın gerçekleşmemesi durumunda 1.sonuca
Alternatif olarak hücreye sonuç yazılacak kısımdır.
Öğr.Gör. Mustafa YAVAŞ [email protected]
28
KARŞILAŞTIRMA FONKSİYONLARI
3. EĞER FONKSİYONU
=EĞER(B2<50; "KALDI"; "GEÇTİ")
ŞART : B2 hücresindeki değerin 50’den büyük olup
olmaması
Sonuç1 : Eğer bu değer 50’den küçükse o hücreye
KALDI yazılacak..
Sonuç2 : Şartı sağlamıyosa (50 veya 50’den büyükse)
o hücreye GEÇTİ yazılacak..
Öğr.Gör. Mustafa YAVAŞ [email protected]
29
EXCEL (Mantıksal Fonksiyonlar)

VE fonksiyonu
(Birden fazla şartın aynı anda gerçekleştirilebilmesi için
kullanılan bir fonksiyondur. Eğer fonksiyonuyla birlikte
kullanılır.)
=VE(sart1;sart2;……)
=EĞER(VE(A2>80;B2>90); "Geçtiniz"; "Kaldınız")
A2 hücresindeki değer 80’den büyükse ve B2
hücresindeki değer de 90’dan büyükse Geçtiniz yazısı
yazacak, yoksa Kaldınız yazısı yazacaktır.
Öğr.Gör. Mustafa YAVAŞ [email protected]
30
EXCEL (Mantıksal Fonksiyonlar)

YADA fonksiyonu
(2 veya daha fazla şarttan herhangi birinin gerçekleşmesi
durumunda kullanılır.)
=YADA(sart1;sart2;……)
=EĞER(YADA(A2<50;B2>5); "KALDI"; "GEÇTİ")
A2 hücresindeki değer 50’den küçükse veya B2
hücresindeki değer 5’ten büyükse KALDI yazısı yazacak,
yoksa GEÇTİ yazısı yazacaktır.
Öğr.Gör. Mustafa YAVAŞ [email protected]
31
EXCEL (Mantıksal Fonksiyonlar)

DEĞİL fonksiyonu
(Belirtilen bir şartın olamaması durumunda kullanılır.)
=DEĞİL(şart)
=EĞER(DEĞİL(A2>=50); "KALDI"; "GEÇTİ")
A2 hücresindeki değer 50’ye eşit veya 50’den büyük
değilse KALDI yazısı yazacak, yoksa GEÇTİ yazısı
yazacaktır.
Öğr.Gör. Mustafa YAVAŞ [email protected]
32
EXCEL (Mantıksal Fonksiyonlar)

EĞERSAY fonksiyonu
(Belirlenen veri alanında belirli şarta uygun verilerin
sayısını belirlemek için kullanılır.)
=EĞERSAY(belirtilen aralık; şart)
=EĞERSAY(D2:D8; ">75 ")
D2 hücresi ile D8 hücresi arasındaki hücrelerden değeri
75’den büyük olanlarının sayısını verir.
Öğr.Gör. Mustafa YAVAŞ [email protected]
33
Öğr.Gör. Mustafa YAVAŞ [email protected]
34
Download

Ders Notu_1 - Öğr.Gör.Mustafa YAVAŞ