VYBRANÉ VYHLEDÁVACÍ FUNKCE
V EXCELU 2007
T
Tomáš
áš Louda
L d
xlout04
SVYHLEDAT
|
SVYHLEDAT(hledat,tabulka,sloupec,typ)
Hledat je hodnota, kterou hledáme v prvním sloupci
Tabulky.
y Tabulka jsou dva nebo více sloupců údajů, kde
hledáme argument z Hledat.
y Sloupec
Sl
j čí
je
číslo
l sloupce
l
v Tabulce,
T b l
z něhož
ěh ž funkce
f k
vrací odpovídající hodnotu.
y Typ: NEPRAVDA je přesná shoda, PRAVDA
nepřesná shoda (bude vrácena nejvyšší hodnota,
která je menší než hodnota hledat)
y
SVYHLEDAT – PŘÍKLAD Č.1 NA NEPŘESNOU
SHODU
|
Pomocí SVYHLEDAT vyhledáme na jakou
slevu mají zákazníci dle své platby nárok.
y
=SVYHLEDAT(B2;$F$2:$H$6;3;PRAVDA)
SVYHLEDAT – PŘÍKLAD Č.2 – ADRESA A
ZACHOVÁNÍ FUNKCIONALITY
|
|
Použijeme
j
SVYHLEDAT,, abychom
y
při
p
výběru osoby ze seznamu dostali její
adresu.
| =SVYHLEDAT($B$2;E3:I16;3;0)
Pro případ, že bychom vkládali do zdrojové
tabulky další sloupce, použijeme funkci
SLOUPEC pro zachování
h á í funkcionality.
f k i
li
| =SVYHLEDAT($B$2;E3:I16;SLOUPEC(G3)SLOUPEC(E3)+1 0)
SLOUPEC(E3)+1;0)
SVYHLEDAT – PŘÍKLAD Č.3 – MARŽE
|
Použijeme SVYHLEDAT, pro zobrazení jména
výrobku (resp.
(resp Marže) při zadání ID výrobku:
|
|
=SVYHLEDAT($B3;MARZE;2;0)
S pomocíí JE.PRÁZDNÉ
JE PRÁZDNÉ a KDYŽ můžeme
ůž
upravit, aby nehyzdila při nezadání ID:
=KDYŽ(JE.PRÁZDNÉ($B3);“_";SVYHLEDAT($
KDYŽ(JE PRÁZDNÉ($B3) “ " SVYHLEDAT($
B3;MARZE;2;0))
| ÚKOL: Zapište
Z išt vzorec pro Prodejní
P d j í cenu; upravte
t
pro případ použití nové marže:
| =KDYŽ(JE.PRÁZDNÉ($E3);
=KDYŽ(JE PRÁZDNÉ($E3);
SVYHLEDAT($B3;MARZE;6;0)*(1+SVYHLEDAT($
;
; ; ));
B3;MARZE;7;0));
SVYHLEDAT($B3;MARZE;6;0)*(1+$E3))
|
SVYHLEDAT – PŘÍKLAD Č.4 – BILANČNÍ
KONTINUITA
|
ÚKOL: Na dvou listech jsou umístěny obratové
předvahy za rok 2008 a 2009. Úkolem je pomocí
funkce SVYHLEDAT zjistit, jestli platí bilanční
kontinuita, tj. jestli se Počáteční stav roku 2009
rovná Konečnému stavu roku 2008.
|
Jestli ne, jaké účty se nerovnají a o kolik?
|
První za 2 b.,
b druhý a třetí za 1 b.
b
|
=SVYHLEDAT(A2;'2008'!$A:$F;6;NEPRAVDA)
POZVYHLEDAT
| POZVYHLEDAT(co;prohledat;shoda)
y
Vrátí relativní pozici hledané hodnoty
Co je hodnota
hodnota, kterou hledáme
hledáme.
| Prohledat je prohledávaná oblast; matice nebo
oodkaz
a na
a matici
a c
| Shoda může být
|
| -1
: najde nejmenší hodnotu, která je větší nebo rovna hledané
hodnotě
|0
|1
: přesná shoda
: najde největší hodnotu,
hodnotu která je menší nebo rovna hledané
hodnotě
INDEX
|
2 varianty:
| INDEX (pole; řádek; sloupec)
y Pole je oblast buněk nebo maticová konstanta.
| Pokud argument pole určuje oblast pouze s jedním řádkem
nebo sloupcem,
sloupcem může být příslušný argument (řádek nebo
sloupec) vynechán.
y Řádek určuje řádek Pole.
y Sloupec určuje sloupec Pole.
Pole
| Jeden z argumentů Řádek a Sloupec je vždy povinný.
| INDEX
(odkaz; řádek; sloupec; oblast)
y
pro nesouvislé plochy; první 3 argumenty fungují
obdobně
bd b ě
y
Oblast určuje oblast, kde hledáme průsečík. Oblasti
číslujeme od 1. Pokud je Oblast vynechána, použije funkce
automaticky
t
ti k oblast
bl t číslo
čí l 1.
1
PŘÍKLAD Č.5
5
|
– VÝROBKY
Použijeme
j
POZVYHLEDAT a INDEX k
zjištění ceny výrobku dle jeho parametru;
šířky a délky.
|
=INDEX(CENY;
POZVYHLEDAT(C2;SIRKA;0);
POZVYHLEDAT(C3;DELKA;0))
PŘÍKLAD Č.6
6
|
ÚKOL: Použijte
j POZVYHLEDAT,, INDEX a MIN
k zjištění u každého výrobku, která firma ho
prodává za nejnižší cenu…
|
|
– NEJLEVNĚJŠÍ PRODÁVAJÍCÍ
=INDEX($B$1:$E$1;;POZVYHLEDAT(MIN($B2:$
E2);$B2:$E2;0))
Co ale, když je více minimálních hodnot.
ZDROJE
|
office.microsoft.com/cs-cz/excel
|
dataspectrum.cz
DĚKUJI ZA POZORNOST
Download

vybrané vyhledávací funkce vybrané vyhledávací