Računarske mreže 3/1
Osnovne IOS komande – 1 deo
Pristup sviču ili ruteru
 Direktno preko konzolnog porta (console port) na ureĎaju
o Nije potrebno konfigurisati ruter za ovaj pristup
 Telnet – preko mreže
o Mrežna konekcija
o Mrežna konfiguracija na oba kraja (IP adresa, subnet maska, itd.)
o Telnet lozinka (password) konfigurisana na ruteru
 Modem – Nećemo raditi !!!
Direktan pristup sviču ili ruteru
 Konzolni port na ruteru ili sviču omogućava nam povezivanje “dumb” terminala ili direktno
povezivanje računara sa terminal-emulatorskim softverom
 Na ruteru ne trebaju nikakve IP adrese ili druga konfiguraciona podešavanja
 Koristi se za:
o Configuring a device that has never been configured.
o Configuring a device directly, because you are physically located where the device is.
o Troubleshooting a device that you can no longer access remotely.
o Performing password recovery.
Terminal Emulatori
 HyperTerminal: U okviru Windows OS-a
 Teraterm: Free download (preporuka)
 Podešavanja:
o 9600 Baud
o 8 Data Bits
o 1 Stop Bit
o No Parity
Podizanje rutera ili sviča – bez konfigurisanja korak po korak
Ako ruter nema sačuvanu konfiguraciju, nakon njegovog podizanja i odreĎenog početnog teksta na ekranu,
trebalo bi da vidimo sledeće pitanje:
Would you like to enter the initial configuration dialog? [yes/no]: n




Uvek odgovaramo sa “n” za NE.
Nećemo koristiti SETUP mod.
Ako slučajno pritisnete slovo “y” i uĎete u Setup Mode, za izlazak koristiti kombinaciju tastera
(CTRL-C).
Sačekati par sekundi i pritisnuti Enter.
Na nekim ruterima moguće je videti sledeću poruku.
Would you like to terminate autoinstall? [yes/no]: y
<There will be several lines of output>
Router>
1
Copyright © D.Čabarkapa 2012, Tehnička škola Šabac
Računarske mreže 3/1
Uključivanje rutera (sviča) – sa konfiguracijom
Ruter ili svič već oposeduje (pre-existing) konfiguraciju.
Ako nakon podizanja rutera ili sviča umesto poruke vidite odziv na ekranu:
Router>


Neko je već sačuvao konfiguraciju u ruteru (startup-config).
Pošto je najbolja praksa kreirati nove labove bez prethodnog korišćene konfiguracije rutera,
potrebno je izbrisati startup-config i restartovati ruter
Router> enable

Ako je potrebno uneti lozinku, ona je obično: class ili cisco
Router# erase startup-config

Zatim isključiti ruter i ponovo ga uključiti.
User Mode i Privilege Mode, pomoć i prečice za komande
User Mode (ruter ili svič)
Router>
Switch>


User mode nam omogućava da se vidi stanje rutera, ali ne omogućava bilo kakvu izmenu
konfiguracije
Ne mešati “user” mode sa terminom “users” računarske mreže.
Privilege Mode (ruter ili svič)
Router> enable
Router#

<user mode>
<privilege mode>
Omogućava da administratori menjaju konfiguraciju rutera
Router# disable
<privilege mode>
Router> enable
Router#
<user mode>
<privilege mode>
2
Copyright © D.Čabarkapa 2012, Tehnička škola Šabac
Računarske mreže 3/1
Pomoć (Help) (Ruter i Svič)
Router> ?
Exec commands:
access-enable
access-profile
clear
<text omitted>
ping
ppp
--More-


Create a temporary Access-List entry
Apply user-profile to interface
Reset functions
Send echo messages
Start IETF Point-to-Point Protocol (PPP)
Pritisnuti Space Bar za skrolovanje i pregled preostalih komandi na ekranu.
Pritisnuti Enter ili Return taster za skrolovanje liniju po liniju liste naniže.
Pritisak na bilo koji drugi taster vrši izlazak iz liste komandi.
Router> show ?
alps
backup
c2600
call
cca
ccm-manager
cdapi
cef
class-map
clock
<text omitted>
--More—
Router> show
Alps information
Backup status
Show c2600 information
Show call
CCA information
Call Manager Application information
CDAPI information
Cisco Express Forwarding
Show QoS Class Map
Display the system clock
Router> show interfaces ?
Async
Async interface
BRI
ISDN Basic Rate Interface
BVI
Bridge-Group Virtual Interface
<text omitted>
Router> show interfaces
Skraćene komande (ruter i svič)
Router# sh inter
Je isto kao i
Router# show interfaces
3
Copyright © D.Čabarkapa 2012, Tehnička škola Šabac
Računarske mreže 3/1
Global Configuration Mod
Komande EXIT, END i Control-Z
Router>ena
Router#configure terminal <Must be in privileged mode>
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#?
Configure commands:
access-list
Add an access list entry
<text omitted>
Router(config)#exit
00:03:20: %SYS-5-CONFIG_I: Configured from console by con
Router#config t
Enter configuration commands, one per line.
End with CNTL/Z.
Router(config)#exit
00:03:34: %SYS-5-CONFIG_I: Configured from console by console
Router#
Hostname – definisanje imena rutera ili sviča
Router#config t
Router(config)#hostname R1
R1(config)#
 Vrši se iz konfiguracionog moda
Pregled, čuvanje i brisanje konfiguracija
running-config





running-config fajl je konfiguracioni fajl koji se čuva u RAM memoriji.
Sve izmene u konfiguraciji ureĎaja se čuvaju u running-config fajlu.
To je konfiguracija koju ruter trenutno koristi.
running-config fajl se gubi kada ruter izgubi napajanje ili se restartuje
running-config se koristi iz Privilege moda.
Router#show running-config
Current configuration : 542 bytes
!
version 12.2
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
!
line con 0
4
Copyright © D.Čabarkapa 2012, Tehnička škola Šabac
Računarske mreže 3/1
line aux 0
line vty 0 4
!
end
Router#
startup-config




startup-config fajl je sačuvana konfiguracija u NVRAM memoriji.
Ako se startup-config fajl nalazi u NVRAM-u kada se ruter podiže (boots up), on će se ikopirati u
running-config.
running-config je ono što će ruter koristiti.
startup-config se koristi iz Privilege moda.
Router#show startup-config
startup-config is not present
Router#
Copy running-config startup-config



running-config treba povremeno iskopirati u startup-config kada smo zadovoljni podešavanjima
mreže i ureĎaja i ne želimo da ih izgubimo
startup-config bi trebalo da uvek odgovara running-config fajlu u slučaju nestanka napajanja i
slično…
ova komanda je Privilege mode komanda.
Router#copy running-config startup-config
Destination filename [startup-config]? <Press Enter>
Building configuration...
[OK]
Router#show startup-config
Current configuration : 542 bytes
!
version 12.2
!
interface FastEthernet0/0
<text omitted>
Erase startup-config




Ako smo zavšili podešavanja rutera u labu, potrebno je na kraju izbrisati startup-config fajl.
Ako pokrenete lab, i ne dobijete poruku:
Would you like to enter the initial configuration dialog? [yes/no]:
Tada treba izbrisati startup-config i restartovati ruter.
Privilege mode komanda.
Router#erase startup-config
Erasing the nvram filesystem will remove all files! Continue? [confirm]
Enter>
[OK]
Erase of nvram: complete
Router#
5
<Press
Copyright © D.Čabarkapa 2012, Tehnička škola Šabac
Računarske mreže 3/1
copy running-config startup-config
Router# copy running-config startup-config
ili
Router# copy running startup
ili
Router# copy run start
ili
Može se koristiti bilo koja od navedenih komandi ili skraćenih komandi.
reload
Router#erase startup-config
Router#reload
Interfejsi rutera
Interfejsi

Brz pregled interfejsa.
Router#show ip interface brief
Interface
IP-Address
FastEthernet0/0
unassigned
Serial0/0
unassigned
BRI0/0
unassigned
BRI0/0:1
unassigned
BRI0/0:2
unassigned
Serial0/1
unassigned
Router#
OK?
YES
YES
YES
YES
YES
YES
Method
unset
unset
unset
unset
unset
unset
Status
administratively
administratively
administratively
administratively
administratively
administratively
Protocol
down down
down down
down down
down down
down down
down down
Konfigurisanje Ethernet interfejsa



Interfejsi mogu biti različiti!
Definiše se IP adresa i subnet maska
no shutdown – UKLJUČUJE interfejs (ne zaboraviti !!!).
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#inter fastethernet 0/0
Router(config-if)#ip add 172.30.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#end
Router#
6
Copyright © D.Čabarkapa 2012, Tehnička škola Šabac
Računarske mreže 3/1
Konfigurisanje serijskog interfejsa



Serijski interfejsi imaju različite oznake!
Definiše se IP adresa i subnet maska
no shutdown – UKLJUČUJE interfejs (ne zaboraviti !!!).
R1(config)#inter serial 0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
7
Copyright © D.Čabarkapa 2012, Tehnička škola Šabac
Download

Osnovne IOS komande